summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Watson <davejwatson@fb.com>2017-08-17 14:13:28 -0700
committerDave Watson <davejwatson@fb.com>2017-08-24 08:51:39 -0700
commit60663c8f69ebfe14043d2436c94a4c9514038d9b (patch)
tree039077d3f87d25f1473ea936c32dd0564ccb629c /configure.ac
parent7f1aebadbfcbb2e96ca885663d1f8c9213b23e94 (diff)
downloadlibunwind-60663c8f69ebfe14043d2436c94a4c9514038d9b.tar.gz
multilib: XFAIL some tests
Ptrace interface doesn't understand multilib registers, so tests all fail.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1ce4583e..57944d96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -162,6 +162,7 @@ AC_MSG_RESULT([$target_os])
AM_CONDITIONAL(BUILD_COREDUMP, test x$enable_coredump = xyes)
AM_CONDITIONAL(BUILD_PTRACE, test x$enable_ptrace = xyes)
AM_CONDITIONAL(BUILD_SETJMP, test x$enable_setjmp = xyes)
+AM_CONDITIONAL(NO_PTRACE_TEST, test x$build_arch != x$host_arch)
AM_CONDITIONAL(REMOTE_ONLY, test x$target_arch != x$host_arch)
AM_CONDITIONAL(ARCH_AARCH64, test x$target_arch = xaarch64)
AM_CONDITIONAL(ARCH_ARM, test x$target_arch = xarm)
@@ -401,6 +402,7 @@ case "$ac_cv_search_backtrace" in
*) BACKTRACELIB="";;
esac
+
AC_SUBST(build_arch)
AC_SUBST(target_os)
AC_SUBST(arch)