summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index d5c0d6f..65cf906 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -215,7 +215,13 @@ HEADERS_WITH_EXTERNS = \
# '-export-symbols', but we don't use this option, because it would prevent us
# from building some of the gnulib unit tests.
libunistring.sym : $(HEADERS_WITH_EXTERNS)
- for f in $(HEADERS_WITH_EXTERNS); do cat $(srcdir)/$$f; done \
+ for f in $(HEADERS_WITH_EXTERNS); do \
+ if test -f $$f; then \
+ cat $$f; \
+ else \
+ cat $(srcdir)/$$f; \
+ fi; \
+ done \
| $(srcdir)/declared.sh | LC_ALL=C sort | LC_ALL=C uniq \
| grep -v '^_UC' \
> $@-t