summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 6292364..64eca01 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -94,6 +94,16 @@ MOSTLYCLEANFILES += unistring-stdint.h-t
CLEANFILES += unistring-stdint.h
EXTRA_DIST += stdint.mini.h
+# localcharset.h is not public, but its contents is documented.
+nodist_include_HEADERS += unistring-localcharset.h
+unistring-localcharset.h : localcharset.h
+ rm -f $@-t $@
+ cp $(srcdir)/localcharset.h $@-t
+ mv $@-t $@
+BUILT_SOURCES += unistring-localcharset.h
+MOSTLYCLEANFILES += unistring-localcharset.h-t
+CLEANFILES += unistring-localcharset.h
+
# Libtool's library version information for libunistring.
# See the libtool documentation, section "Library interface versions".
LTV_CURRENT=0