summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrank Warmerdam <warmerdam@pobox.com>2005-11-21 03:35:05 +0000
committerFrank Warmerdam <warmerdam@pobox.com>2005-11-21 03:35:05 +0000
commitb86f199feb9d2c4f1648606985b506636c59e44c (patch)
treed2af210f523e01bba08a5524fcc3ed090439df64 /configure.ac
parent7fd3fba4f3ec9dabde67f67e226e498510238fd2 (diff)
downloadlibtiff-git-b86f199feb9d2c4f1648606985b506636c59e44c.tar.gz
preliminary support for MS MDI format, bug 1002
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f930ebf3..ac7d6d3e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -252,6 +252,19 @@ if test "$HAVE_LOGLUV" = "yes" ; then
fi
dnl ---------------------------------------------------------------------------
+dnl Switch on/off support for Microsoft Document Imaging
+dnl ---------------------------------------------------------------------------
+
+AC_ARG_ENABLE(mdi,
+ AS_HELP_STRING([--disable-mdi],
+ [disable support for Microsoft Document Imaging]),
+ [HAVE_MDI=$enableval], [HAVE_MDI=yes])
+
+if test "$HAVE_MDI" = "yes" ; then
+ AC_DEFINE(MDI_SUPPORT,1,[Support Microsoft Document Imaging format])
+fi
+
+dnl ---------------------------------------------------------------------------
dnl Check for ZLIB.
dnl ---------------------------------------------------------------------------
@@ -529,6 +542,7 @@ LOC_MSG([ Documentation directory: ${LIBTIFF_DOCDIR}])
LOC_MSG([ C compiler: ${CC} ${CFLAGS}])
LOC_MSG([ C++ compiler: ${CXX} ${CXXFLAGS}])
LOC_MSG([ Enable runtime linker paths: ${HAVE_RPATH}])
+LOC_MSG([ Support Microsoft Document Imaging: ${HAVE_MDI}])
LOC_MSG()
LOC_MSG([ Support for internal codecs:])
LOC_MSG([ CCITT Group 3 & 4 algorithms: ${HAVE_CCITT}])