summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrey Kiselev <dron@ak4719.spb.edu>2005-10-07 17:27:09 +0000
committerAndrey Kiselev <dron@ak4719.spb.edu>2005-10-07 17:27:09 +0000
commitab000523ed98b5bc14beb1dfbbfbfc85119b6cf0 (patch)
treed09b28218b9fe8144f061678672967a40ffd2416 /configure.ac
parentc59cbfc844285961573db4198c4c37851df94748 (diff)
downloadlibtiff-git-ab000523ed98b5bc14beb1dfbbfbfc85119b6cf0.tar.gz
Make the default strip size configurable via the --with-default-strip-size and
STRIP_SIZE_DEFAULT options
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6055594f..f930ebf3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -432,11 +432,21 @@ dnl ---------------------------------------------------------------------------
AC_ARG_ENABLE(strip-chopping,
AS_HELP_STRING([--disable-strip-chopping],
- [disable support for strip chopping (whether or not to convert single-strip uncompressed images to mutiple strips of ~8Kb to reduce memory usage)]),
+ [disable support for strip chopping (whether or not to convert single-strip uncompressed images to mutiple strips of specified size to reduce memory usage)]),
[HAVE_STRIPCHOP=$enableval], [HAVE_STRIPCHOP=yes])
+AC_ARG_WITH(default-strip-size,
+ AS_HELP_STRING([--with-default-strip-size=SIZE],
+ [default size of the strip in bytes (when strip chopping enabled) [[default=8192]]]),,)
if test "$HAVE_STRIPCHOP" = "yes" ; then
- AC_DEFINE(STRIPCHOP_DEFAULT,TIFF_STRIPCHOP,[Support strip chopping (whether or not to convert single-strip uncompressed images to mutiple strips of ~8Kb to reduce memory usage)])
+ AC_DEFINE(STRIPCHOP_DEFAULT,TIFF_STRIPCHOP,[Support strip chopping (whether or not to convert single-strip uncompressed images to mutiple strips of specified size to reduce memory usage)])
+
+ if test "x$with_default_strip_size" == "x" ; then
+ with_default_strip_size="8192"
+ fi
+
+ AC_DEFINE_UNQUOTED(STRIP_SIZE_DEFAULT,$with_default_strip_size,[Default size of the strip in bytes (when strip chopping enabled)])
+
fi
dnl ---------------------------------------------------------------------------