summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBob Friesenhahn <bfriesen@simple.dallas.tx.us>2015-09-01 15:38:01 +0000
committerBob Friesenhahn <bfriesen@simple.dallas.tx.us>2015-09-01 15:38:01 +0000
commite762ba3de9e64afa8ab83f23601901a9f2a3eee5 (patch)
treecd39eac31552970d74f01d8a3461dfe97d866c15 /Makefile.am
parentba57d5f0b7dd9a47ba3ef276aa7e4dbc067809a8 (diff)
downloadlibtiff-git-e762ba3de9e64afa8ab83f23601901a9f2a3eee5.tar.gz
* CMakeLists.txt, Makefile.am, configure.ac: Applied patches by
Roger Leigh (via tiff mailing list on 2015-09-01). CMake build is now included in 'distcheck' target. Builds with CMake 2.8.9 and newer. Tar is now resquested to use POSIX PAX format.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8f310beb..012794b2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,6 +49,16 @@ EXTRA_DIST = \
dist_doc_DATA = $(docfiles)
+distcheck-hook:
+ mkdir $(distdir)/_build/cmake \
+ && cd $(distdir)/_build/cmake \
+ && cmake ../.. \
+ && $(MAKE) \
+ && ctest -V \
+ && $(MAKE) DESTDIR=../../_inst/cmake install
+ $(RM) -r $(distdir)/_build/cmake
+ $(RM) -r $(distdir)/_inst/cmake
+
SUBDIRS = port libtiff tools build contrib test man html
release: