summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a00ebc7..0cd48a3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -24,13 +24,11 @@ LDADD = ../lib/libtasn1.la ../gl/libgnu.la
EXTRA_DIST = Test_parser.asn Test_tree.asn Test_tree_asn1_tab.c \
Test_encoding.asn pkix.asn TestIndef.p12 choice.asn coding-decoding2.asn \
- TestIndef2.p12 TestIndef3.der
+ TestIndef2.p12 TestIndef3.der TestCertOctetOverflow.der
# For crlf.
EXTRA_DIST += crlf.cer crl.der ocsp.der
-dist_check_SCRIPTS = crlf benchmark
-
-dist_check_SCRIPTS += threadsafety
+dist_check_SCRIPTS = crlf benchmark threadsafety decoding
MOSTLYCLEANFILES = Test_parser_ERROR.asn
@@ -41,7 +39,7 @@ check_PROGRAMS = Test_parser Test_tree Test_encoding Test_indefinite \
TESTS = Test_parser Test_tree Test_encoding Test_indefinite \
Test_errors Test_simple Test_overflow crlf threadsafety \
Test_strings Test_choice Test_encdec copynode coding-decoding2 \
- strict-der Test_choice_ocsp
+ strict-der Test_choice_ocsp decoding
TESTS_ENVIRONMENT = \
ASN1PARSER=$(srcdir)/Test_parser.asn \