summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 455ef69..056aa84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,11 @@ gl_EARLY
lgl_EARLY
AC_PROG_YACC
+AC_ARG_ENABLE(doc,
+ AS_HELP_STRING([--disable-doc], [don't generate any documentation]),
+ enable_doc=$enableval, enable_doc=yes)
+AM_CONDITIONAL(ENABLE_DOC, test "$enable_doc" != "no")
+
dnl Checks for programs.
AM_MISSING_PROG(HELP2MAN, help2man, $missing_dir)
AC_LIBTOOL_WIN32_DLL