summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 64964f67..97704170 100644
--- a/meson.build
+++ b/meson.build
@@ -304,7 +304,9 @@ if python.found()
endif
message('Python module quart found: @0@'.format(quart_found.to_string('YES', 'NO')))
-if not have_apache or not quart_found or not have_autobahn
+gnutls_dep = dependency('gnutls', required : get_option('tests'))
+
+if not have_apache or not quart_found or not have_autobahn or not gnutls_dep.found()
warning('Some regression tests will not be compiled due to missing libraries or modules. Please check the logs for more details.')
endif
@@ -433,6 +435,7 @@ summary({
'Tests requiring Quart' : quart_found,
'Fuzzing tests' : get_option('fuzzing').enabled(),
'Autobahn tests' : have_autobahn,
+ 'PKCS#11 tests' : gnutls_dep.found(),
'Install tests': get_option('installed_tests'),
'Unix sockets' : unix_socket_dep.found(),
},