summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in41
1 files changed, 27 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 3ed1a4b1..60616052 100644
--- a/configure.in
+++ b/configure.in
@@ -3,7 +3,7 @@ dnl *** Initialize automake and set version ***
dnl *******************************************
AC_PREREQ(2.53)
-AC_INIT(libsoup, 2.27.1)
+AC_INIT(libsoup, 2.27.4)
AC_CONFIG_SRCDIR(libsoup-2.4.pc.in)
AM_INIT_AUTOMAKE([foreign])
@@ -143,22 +143,23 @@ dnl **********************************
dnl Allow autogening even without AM_PATH_LIBGCRYPT available
m4_ifdef([AM_PATH_LIBGCRYPT],,[m4_define(AM_PATH_LIBGCRYPT,)])
AC_ARG_ENABLE(ssl,
- AS_HELP_STRING([--enable-ssl], [Turn on Secure Sockets Layer support (default=yes)]),,
+ AS_HELP_STRING([--disable-ssl], [Disable SSL/TLS support (not recommended)]),,
enable_ssl=auto)
+have_ssl=no
if test "$enable_ssl" != "no"; then
PKG_CHECK_MODULES(LIBGNUTLS, gnutls,
[AM_PATH_LIBGCRYPT([], have_ssl=yes, have_ssl=no)], have_ssl=no)
- if test "$have_ssl" = "yes"; then
- AC_DEFINE(HAVE_SSL, 1, [Defined if you have SSL support])
- SSL_REQUIREMENT="gnutls"
+fi
+if test "$have_ssl" = "yes"; then
+ AC_DEFINE(HAVE_SSL, 1, [Defined if you have SSL support])
+ SSL_REQUIREMENT="gnutls"
+else
+ if test "$enable_ssl" = "no"; then
+ AC_MSG_WARN(Disabling SSL support);
else
- if test "$enable_ssl" = "auto"; then
- AC_MSG_WARN(Disabling SSL support);
- enable_ssl=no;
- else
- AC_MSG_ERROR(Could not configure SSL support);
- fi
+ AC_MSG_ERROR([Could not configure SSL support.
+Pass "--disable-ssl" if you really want to build without SSL support]);
fi
fi
@@ -241,8 +242,20 @@ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
-Wall -Wstrict-prototypes -Wmissing-declarations \
-Wmissing-prototypes -Wnested-externs -Wpointer-arith \
-Wdeclaration-after-statement -Wformat=2 -Winit-self \
- -Wmissing-include-dirs -Wundef -Waggregate-return \
- -Wmissing-format-attribute"
+ -Waggregate-return -Wmissing-format-attribute"
+
+ for option in -Wmissing-include-dirs -Wundef; do
+ SAVE_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $option"
+ AC_MSG_CHECKING([whether gcc understands $option])
+ AC_TRY_COMPILE([], [],
+ has_option=yes,
+ has_option=no,)
+ AC_MSG_RESULT($has_option)
+ if test $has_option = no; then
+ CFLAGS="$SAVE_CFLAGS"
+ fi
+ done
fi
if test "$os_win32" != yes; then
@@ -317,7 +330,7 @@ if test "$APACHE_HTTPD" != "no" -a -n "$APACHE_MODULE_DIR" -a -n "$APACHE_SSL_MO
fi
else
have_apache=0
- if test "$APACHE_HTTPD" == "no" -o -z "$APACHE_MODULE_DIR"; then
+ if test "$APACHE_HTTPD" = "no" -o -z "$APACHE_MODULE_DIR"; then
MISSING_REGRESSION_TEST_PACKAGES="$MISSING_REGRESSION_TEST_PACKAGES apache"
else
MISSING_REGRESSION_TEST_PACKAGES="$MISSING_REGRESSION_TEST_PACKAGES mod_ssl"