summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2013-12-11 18:15:13 +0100
committerDan Winship <danw@gnome.org>2014-02-08 13:20:21 +0100
commit094eee8d1e0ac31e83f45e026ef26688e1468884 (patch)
treef5aa4dc398c5117ca5e3392794811fd39c048f22 /tests/Makefile.am
parent64e667bda5009c8f1acd03659c457e26b16457a6 (diff)
downloadlibsoup-094eee8d1e0ac31e83f45e026ef26688e1468884.tar.gz
tests: Add resources/* to soup-test.gresource, add utility functions
Add the files in resources/ to soup-test.gresource, and add soup_test_load_resource() to get the contents of one of them, and then use this in places that were previously reading them by hand. Except forms-test, which needs to pass a filename to curl, so have it use index.txt instead of one of the resource files. Now none of the tests access the resources/ directory at runtime. Also add soup_test_get_index() to read index.txt rather than reimplementing it in multiple test programs.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am19
1 files changed, 4 insertions, 15 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 76a87fa7..f7293b12 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -77,21 +77,10 @@ httpd.conf: $(httpd_conf_in)
BUILT_SOURCES = httpd.conf
endif
-soup-tests.gresource: soup-tests.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/soup-tests.gresource.xml)
- $(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) $<
-
-RESOURCES = \
- resources/atom.xml \
- resources/home.gif \
- resources/html_binary.html \
- resources/mbox \
- resources/mbox.gz \
- resources/mbox.raw \
- resources/mbox.zlib \
- resources/ps_binary.ps \
- resources/rss20.xml \
- resources/test.html \
- resources/text_binary.txt
+RESOURCES = $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/soup-tests.gresource.xml)
+
+soup-tests.gresource: soup-tests.gresource.xml $(RESOURCES)
+ $(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) $<
EXTRA_DIST = \
htdigest \