summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2017-11-28 18:06:08 +0800
committerTomas Popela <tpopela@redhat.com>2018-04-11 12:39:20 +0200
commitb4923f8bc8e3c957b4fd992e6280514b88198500 (patch)
tree8dfd4f0504b4de79fdf572944baeecfceae855dd /meson.build
parent0c8f69ba632bdd858c208ed0021f455616d7aaeb (diff)
downloadlibsoup-b4923f8bc8e3c957b4fd992e6280514b88198500.tar.gz
meson: Re-word TLS check
Re-word the sections where we check for real TLS support from GIO, as this support currently may be provided via glib-networking (GNUTLS) or glib-openssl (OpenSSL and possibly libressl). Let people know that either glib-networking and glib-openssl are required and supported for libsoup to work.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 238876e3..dcba6650 100644
--- a/meson.build
+++ b/meson.build
@@ -60,9 +60,9 @@ if host_machine.system() == 'windows'
endif
###################
-# glib-networking #
+# GIO TLS support #
###################
-check_glib_networking_src = '''#include <gio/gio.h>
+check_gio_tls_src = '''#include <gio/gio.h>
int main(void) {
return !g_tls_backend_supports_tls (g_tls_backend_get_default ());
}
@@ -70,8 +70,8 @@ int main(void) {
enable_tls_check = get_option('tls_check')
if enable_tls_check
- if not cc.compiles(check_glib_networking_src, name : 'glib-networking supports TLS', dependencies : glib_dep)
- error('libsoup requires glib-networking for TLS support')
+ if not cc.compiles(check_gio_tls_src, name : 'GIO has real TLS support', dependencies : glib_dep)
+ error('libsoup requires glib-networking or glib-openssl for TLS support')
endif
endif