summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPatrick Griffis <pgriffis@igalia.com>2021-05-02 13:20:12 -0500
committerCarlos Garcia Campos <cgarcia@igalia.com>2021-05-16 15:28:26 +0200
commit1a1d29c3114ca86c673d0c0b02a492d0962dcfe8 (patch)
tree763c3e343df379e617d61de79cf76e70084932e5 /meson.build
parent0b67d5fcef5053fe7786eed60ea167ba0a2da16a (diff)
downloadlibsoup-1a1d29c3114ca86c673d0c0b02a492d0962dcfe8.tar.gz
Add initial HTTP2 backend
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 17 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 157da832..3daca77b 100644
--- a/meson.build
+++ b/meson.build
@@ -100,6 +100,8 @@ gio_dep = dependency('gio-2.0', version : glib_required_version,
glib_deps = [glib_dep, gobject_dep, gio_dep]
+libnghttp2_dep = dependency('libnghttp2')
+
sqlite_dep = dependency('sqlite3', required: false)
# Fallback check for sqlite, not all platforms ship pkg-config file
@@ -289,7 +291,20 @@ else
have_autobahn = find_program('wstest', required: get_option('autobahn')).found()
endif
-if not have_apache or not have_autobahn
+# Quart server used for HTTP/2 tests
+pymod = import('python')
+quart_found = false
+
+python = pymod.find_installation('python3')
+if python.found()
+ ret = run_command(python, '-c', 'import importlib\nassert(importlib.find_loader("quart"))')
+ if ret.returncode() == 0
+ quart_found = true
+ endif
+endif
+message('Python module quart found: @0@'.format(quart_found.to_string('YES', 'NO')))
+
+if not have_apache or not quart_found or not have_autobahn
warning('Some regression tests will not be compiled due to missing libraries or modules. Please check the logs for more details.')
endif
@@ -415,6 +430,7 @@ summary({
summary({
'All tests' : get_option('tests'),
'Tests requiring Apache' : have_apache,
+ 'Tests requiring Quart' : quart_found,
'Fuzzing tests' : get_option('fuzzing').enabled(),
'Autobahn tests' : have_autobahn,
'Install tests': get_option('installed_tests'),