summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2021-04-19 17:30:19 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2021-04-19 17:30:19 +0800
commit17c6cfe361cd1d2cadc7e488c27fcb84a986a56b (patch)
tree86552e6f23cc68f047ab397853958f7d47222d5d /meson.build
parent6ba415885e332ac0d34e0f03686105870e937276 (diff)
downloadlibsoup-17c6cfe361cd1d2cadc7e488c27fcb84a986a56b.tar.gz
meson.build: Fix Windows config for ntlm-auth
There is no ntlm-auth program for Windows, so just use a dummy dependency for it on Windows builds.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 31430cd1..c1dabece 100644
--- a/meson.build
+++ b/meson.build
@@ -339,6 +339,8 @@ if host_machine.system() != 'windows'
add_project_arguments('-DUSE_NTLM_AUTH=1', language : 'c')
add_project_arguments('-DNTLM_AUTH="' + ntlm_auth.path() + '"', language : 'c')
endif
+else
+ ntlm_auth = dependency('', required: false)
endif
#########################