summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Garcia Campos <cgarcia@igalia.com>2019-07-04 09:31:39 +0200
committerCarlos Garcia Campos <carlosgc@gnome.org>2019-07-31 14:09:00 +0200
commit13cea0fdf2c935af4e38849c8cd550e9b654b2b9 (patch)
tree6410cc559e45dd7bf5ab426b042861dd168a8f66 /meson.build
parent5c45253243a2deca4880d4f614f2932373445cf9 (diff)
downloadlibsoup-13cea0fdf2c935af4e38849c8cd550e9b654b2b9.tar.gz
WebSockets: add support for permessage-deflate extension
Add new API to add WebSocket extensions to SoupSession and SoupServer and include an implementation of permessage-deflate extension (see RFC 7692). In the client side, supported extensions are added to the session as sub-features of a new session feature, SoupWebsocketExtensionManager. In the client side, supported extensions are added/removed directly using the new SoupServer API. All functions to negotiate the handshake (client_prepare, client_verify, server_check and server_process) have now a _with_extensions alternative to handle the extensions.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 94098645..99a1ea5f 100644
--- a/meson.build
+++ b/meson.build
@@ -159,6 +159,21 @@ if enable_tls_check
endif
endif
+libz_dep = dependency('zlib', required : false)
+if not libz_dep.found()
+ if cc.get_id() != 'msvc'
+ libz_dep = cc.find_library('z', required : false)
+ else
+ libz_dep = cc.find_library('zlib1', required : false)
+ if not libz_dep.found()
+ libz_dep = cc.find_library('zlib', required : false)
+ endif
+ endif
+ if not libz_dep.found() or not cc.has_header('zlib.h')
+ libz_dep = subproject('zlib').get_variable('zlib_dep')
+ endif
+endif
+
#################################
# Regression tests dependencies #
#################################