summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPatrick Griffis <pgriffis@igalia.com>2021-06-04 10:14:34 -0500
committerPatrick Griffis <pgriffis@igalia.com>2021-06-04 10:15:12 -0500
commit2b511ed96c43be26162b5adb292cc23666dc1c13 (patch)
tree305d2771ec63f14328625a729d11c846996de15d /meson.build
parent2dae529ab45b8693b1771ccca89b055eda76561b (diff)
downloadlibsoup-2b511ed96c43be26162b5adb292cc23666dc1c13.tar.gz
build: Add pkcs11_tests option to explicitly enable/disable them
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 4952d513..6c495518 100644
--- a/meson.build
+++ b/meson.build
@@ -309,7 +309,7 @@ if not get_option('http2_tests').disabled()
endif
endif
-gnutls_dep = dependency('gnutls', required : get_option('tests'))
+gnutls_dep = dependency('gnutls', required : get_option('pkcs11_tests'))
if not have_apache or not quart_found or not have_autobahn or not gnutls_dep.found()
warning('Some regression tests will not be compiled due to missing libraries or modules. Please check the logs for more details.')
@@ -440,7 +440,7 @@ summary({
'Tests requiring Quart' : quart_found,
'Fuzzing tests' : get_option('fuzzing').enabled(),
'Autobahn tests' : have_autobahn,
- 'PKCS#11 tests' : gnutls_dep.found(),
+ 'PKCS #11 tests' : gnutls_dep.found(),
'Install tests': get_option('installed_tests'),
'Unix sockets' : unix_socket_dep.found(),
},