summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2021-06-14 18:14:54 -0400
committerPatrick Griffis <tingping@tingping.se>2021-06-16 20:03:13 +0000
commitfcc79a377ec1e8e38c0554233bb565e41e0e3e94 (patch)
tree3439c132fe168414b19ed44c84ac16571e5b0786 /meson.build
parent6bc0b68fe911e67c9b18aa2f0ea39c25c2a90f6a (diff)
downloadlibsoup-fcc79a377ec1e8e38c0554233bb565e41e0e3e94.tar.gz
Meson: Fix fallback to sqlite3 subproject
Meson's wrapdb had both sqlite and sqlite3 but the former is outdated.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 09886bf4..4dfd8c15 100644
--- a/meson.build
+++ b/meson.build
@@ -112,7 +112,8 @@ if not sqlite_dep.found()
endif
if not sqlite_dep.found()
- sqlite_dep = subproject('sqlite').get_variable('sqlite_dep')
+ # Allows fallback to subproject
+ sqlite_dep = dependency('sqlite3')
endif
libxml_dep = dependency('libxml-2.0', required: false)