summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPatrick Griffis <pgriffis@igalia.com>2021-04-27 13:29:19 -0500
committerCarlos Garcia Campos <carlosgc@gnome.org>2021-06-02 07:22:46 +0000
commitc775f93c923c615a50987d8eebd0dc325b57c1e4 (patch)
tree1da8cd1114c6e85e9135692c96da647a61ea3305 /meson.build
parentdac4665a0c3858dbde3f59c8ca27007b87b8231f (diff)
downloadlibsoup-c775f93c923c615a50987d8eebd0dc325b57c1e4.tar.gz
ssl-test: Add tests for PKCS#11 pin protected cert
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 64964f67..97704170 100644
--- a/meson.build
+++ b/meson.build
@@ -304,7 +304,9 @@ if python.found()
endif
message('Python module quart found: @0@'.format(quart_found.to_string('YES', 'NO')))
-if not have_apache or not quart_found or not have_autobahn
+gnutls_dep = dependency('gnutls', required : get_option('tests'))
+
+if not have_apache or not quart_found or not have_autobahn or not gnutls_dep.found()
warning('Some regression tests will not be compiled due to missing libraries or modules. Please check the logs for more details.')
endif
@@ -433,6 +435,7 @@ summary({
'Tests requiring Quart' : quart_found,
'Fuzzing tests' : get_option('fuzzing').enabled(),
'Autobahn tests' : have_autobahn,
+ 'PKCS#11 tests' : gnutls_dep.found(),
'Install tests': get_option('installed_tests'),
'Unix sockets' : unix_socket_dep.found(),
},