summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPatrick Griffis <pgriffis@igalia.com>2021-09-01 10:44:54 -0500
committerPatrick Griffis <pgriffis@igalia.com>2021-09-01 10:44:54 -0500
commitbe9ddc363d4b44ead93e70f3a6cf7e729c2a279e (patch)
treef18690058a88c88b5d4118edb07629c8863b3a44 /meson.build
parentbbc59e9acc38f30f92c81ef55d15948d83e859ff (diff)
downloadlibsoup-be9ddc363d4b44ead93e70f3a6cf7e729c2a279e.tar.gz
build: Remove libxml dependency
It is no longer used with the removal of XML-RPC support.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 0 insertions, 16 deletions
diff --git a/meson.build b/meson.build
index e49c9521..95cd5ddc 100644
--- a/meson.build
+++ b/meson.build
@@ -116,22 +116,6 @@ if not sqlite_dep.found()
sqlite_dep = dependency('sqlite3')
endif
-libxml_dep = dependency('libxml-2.0', required: false)
-
-# Fallback check for libxml2, not all platforms ship pkg-config file
-if not libxml_dep.found()
- # Note: The XML include dir needs to be within the INCLUDE envvar,
- # such as <INCLUDEDIR>\libxml2
- libxml2_libname = cc.get_id() == 'msvc' ? 'libxml2' : 'xml2'
- libxml_dep = cc.find_library(libxml2_libname,
- has_headers : 'libxml/tree.h',
- required: false)
-endif
-
-if not libxml_dep.found()
- libxml_dep = subproject('libxml2').get_variable('xml2lib_dep')
-endif
-
cdata = configuration_data()
brotlidec_dep = dependency('libbrotlidec', required : get_option('brotli'))