summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPatrick Griffis <pgriffis@igalia.com>2021-04-22 13:04:37 -0500
committerPatrick Griffis <pgriffis@igalia.com>2021-04-22 13:04:37 -0500
commit9b017240ff19bd29d46acccb7364148aae936b22 (patch)
treed99ccfe55cfb28ff9aff40afcc52478e03c160de /meson.build
parent0a6b2555b7ca74d7b879fa5ff06daf1bd22a56f6 (diff)
downloadlibsoup-9b017240ff19bd29d46acccb7364148aae936b22.tar.gz
build: When tests disabled treat autobahn as disabled
You may still explicitly enable autobahn even with tests disabled
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3881d7c7..5935a942 100644
--- a/meson.build
+++ b/meson.build
@@ -283,7 +283,11 @@ if have_apache
endif
endif
-have_autobahn = find_program('wstest', required: get_option('autobahn')).found()
+if get_option('autobahn').auto() and not get_option('tests')
+ have_autobahn = false
+else
+ have_autobahn = find_program('wstest', required: get_option('autobahn')).found()
+endif
if not have_apache or not have_autobahn
warning('Some regression tests will not be compiled due to missing libraries or modules. Please check the logs for more details.')
@@ -412,6 +416,7 @@ summary({
'All tests' : get_option('tests'),
'Tests requiring Apache' : have_apache,
'Fuzzing tests' : get_option('fuzzing').enabled(),
+ 'Autobahn tests' : have_autobahn,
'Install tests': get_option('installed_tests'),
'Unix sockets' : unix_socket_dep.found(),
},