summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Garcia Campos <cgarcia@igalia.com>2022-04-12 16:45:52 +0200
committerCarlos Garcia Campos <cgarcia@igalia.com>2022-04-22 12:12:41 +0200
commit245955f8aca5ac19c86be7945c36ce1a80a7b703 (patch)
tree7b1e97c92df55b8f07ef0d6d415ead0679969987 /meson.build
parentbdf896b96daca249a83590d5b8f355276e5ff048 (diff)
downloadlibsoup-245955f8aca5ac19c86be7945c36ce1a80a7b703.tar.gz
tests: add support for apache http/2 module
Use mpm_event instead of mpm_prefork because http/2 module doesn't support prefork. For now the server prefers http1 because that's what all the tests using apache expect.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 31653cf5..e16ccda6 100644
--- a/meson.build
+++ b/meson.build
@@ -268,6 +268,9 @@ if have_apache
cdata.set('APACHE_SSL_MODULE_DIR', apache_modules_dirs[1])
message('Apache mod_unixd module directory: ' + (apache_modules_dirs[2] != '' ? apache_modules_dirs[2] : '(none)'))
cdata.set('IF_HAVE_MOD_UNIXD', apache_modules_dirs[2] != '' ? '' : '#')
+ message('Apache HTTP/2 module directory: ' + apache_modules_dirs[3])
+ cdata.set('IF_HAVE_MOD_HTTP2', apache_modules_dirs[3] != '' ? '' : '#')
+ cdata.set('APACHE_HTTP2_MODULE_DIR', apache_modules_dirs[3])
cdata.set('HAVE_APACHE', have_apache)
else
message('Failed to locate necessary Apache modules for full test coverage')