summaryrefslogtreecommitdiff
path: root/libsoup/Makefile.am
diff options
context:
space:
mode:
authorGustavo Noronha Silva <gustavo.noronha@collabora.com>2012-08-20 10:37:17 -0300
committerGustavo Noronha Silva <gns@gnome.org>2012-08-20 10:45:09 -0300
commitd2a1f47dd173cc6642832c33b554c506dc97b7b9 (patch)
treea7145236d46e1867b681fc243ce64d0b49bf2620 /libsoup/Makefile.am
parent207b8aa56d272e20d5d3e052753e15b8fb43214f (diff)
downloadlibsoup-d2a1f47dd173cc6642832c33b554c506dc97b7b9.tar.gz
Add SoupMultipartInputStream for handling multipart responses
SoupMultipartInputStream can be used by the API user to wrap the input stream, and provides API to obtain the next part and its headers, using a SoupFilterInputStream internally for buffer management. https://bugzilla.gnome.org/show_bug.cgi?id=656684
Diffstat (limited to 'libsoup/Makefile.am')
-rw-r--r--libsoup/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/libsoup/Makefile.am b/libsoup/Makefile.am
index fdba1efa..cc99e75d 100644
--- a/libsoup/Makefile.am
+++ b/libsoup/Makefile.am
@@ -44,6 +44,7 @@ soup_headers = \
soup-method.h \
soup-misc.h \
soup-multipart.h \
+ soup-multipart-input-stream.h \
soup-password-manager.h \
soup-portability.h \
soup-proxy-resolver.h \
@@ -144,6 +145,7 @@ libsoup_2_4_la_SOURCES = \
soup-misc.c \
soup-misc-private.h \
soup-multipart.c \
+ soup-multipart-input-stream.c \
soup-password-manager.c \
soup-path-map.h \
soup-path-map.c \