summaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2012-12-12 10:19:00 +0100
committerDan Winship <danw@gnome.org>2013-01-02 15:34:12 -0500
commit586aef885f64352bbd3c1b9e68ae2020f33d5833 (patch)
tree2bb0a0f5a0c6e021553f8b6d02cd01d40689ab11 /docs/reference/Makefile.am
parentb24b8324b15250865f7f44178cb5c5fba80074e8 (diff)
downloadlibsoup-586aef885f64352bbd3c1b9e68ae2020f33d5833.tar.gz
soup-auth-manager: split out connection handling
Add a new SoupConnectionAuth class to help with connection tracking, and make SoupAuthNTLM a subclass of it. Allow a single SoupAuthNTLM to carry state information about multiple connections. Make SoupSession store the SoupConnection a SoupMessage is associated with on the message, and use that from SoupConnectionAuth rather than tracking sockets by hand like SoupAuthManager had previously done. Remove the connection tracking in SoupAuthManager, since it is no longer needed.
Diffstat (limited to 'docs/reference/Makefile.am')
-rw-r--r--docs/reference/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
index 74a6d925..17ae6caf 100644
--- a/docs/reference/Makefile.am
+++ b/docs/reference/Makefile.am
@@ -32,7 +32,7 @@ CFILE_GLOB=
IGNORE_HFILES= soup.h soup-marshal.h soup-enum-types.h \
soup-message-private.h soup-session-private.h \
soup-auth-basic.h soup-auth-digest.h soup-auth-ntlm.h \
- soup-connection.h soup-auth-manager.h soup-auth-manager-ntlm.h \
+ soup-connection.h soup-auth-manager.h soup-connection-auth.h \
soup-message-queue.h soup-path-map.h soup-gnome-features.h \
soup-proxy-resolver.h soup-proxy-resolver-gnome.h \
soup-proxy-resolver-static.h soup-directory-input-stream.h \