summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlex Graveley <alex@ximian.com>2001-09-08 02:20:49 +0000
committerAlex Graveley <orph@src.gnome.org>2001-09-08 02:20:49 +0000
commitfda940a0beefbca36b770f22d5eda7973622d017 (patch)
treef7eb2658599102186e2f1beb145237c1b6652c9c /configure.in
parent63bd2d798578313e4e4a953cbc7097fd5f1fd7f0 (diff)
downloadlibsoup-fda940a0beefbca36b770f22d5eda7973622d017.tar.gz
Rewritten for the new apis, and to be more clean, and to have many
2001-09-07 Alex Graveley <alex@ximian.com> * tests/stress-test.c: Rewritten for the new apis, and to be more clean, and to have many settings for varying simultaneous messages, message counts, iterations, posting of data, etc. * tests/simple-test.c: Rewritten for the new apis, and to be more clean. * tests/server-test.c (main): Added. Simple test for standalone dynamic servers. * tests/mod-server-test.c (callback): Added. Simple test for soup-httpd/apache server modules. * tests/handler-test.c: Added. Stress test for SoupMessage handlers. * tests/cgi-test.c: Added. Simple test for CGI serving. * src/soup-httpd/soup-httpd.c: Use libsoup's SoupServer code for all request processing. soup-httpd becomes a wrapper for module loading and logging. * src/libwsdl/Makefile.am (INCLUDES): Remove WSDL_CFLAGS. * src/libsoup/soup-socket.c (soup_socket_server_accept): Set O_NONBLOCK on the returned SoupSocket. (soup_socket_server_try_accept): Ditto. * src/libsoup/soup-server.c: Reimplement for independent SoupServer support. Remove separate authorization handler concept. Process based on request paths. Import code from soup-httpd to allow standalone dynamic servers, and cgi support. * src/libsoup/soup-queue.c (soup_check_used_headers): Remove special handling of SOAPAction. (soup_queue_connect_cb): Start listening for reads immediately so that we cna process HTTP 1xx intermediate responses. (soup_queue_message): Rename from soup_message_queue. soup_message_queue is now in soup-message.c and simply calls this. * src/libsoup/soup-private.h (RESPONSE_BLOCK_SIZE): Rename existing SoupServer to SoupHost. Create new SoupServer struct. Add server and server_sock elements to SoupMessagePrivate. Move SoupServerHandler definition to soup-server.h. Move define for soup_queue_shutdown to new soup-queue.h. * src/libsoup/soup-ntlm.c: Add mojo for getting a portable alloca. * src/libsoup/soup-message.h: Remove SoupErrorCode. Add SoupKnownErrorCode and SoupErrorClass enums. Add SOUP_ERROR_CANT_CONNECT_PROXY and SOUP_ERROR_CANT_AUTHENTICATE_PROXY for errors related directly to proxy communications. * src/libsoup/soup-message.c (soup_message_new): Take the HTTP method name as the second argument. Remove per-message handlers for authentication and redirection. (soup_message_issue_callback): Uses finalize_message to avoid double cleanup. Remove error argument, as they should be set using soup_message_set_error. (soup_message_run_handlers): Run per-message handlers followed by global handlers, if a handler requeues a message we stop processing. If the invoke_type is POST_BODY, we issue the final callback. (soup_message_remove_handler): Make public. (soup_message_set_error): Impl (soup_message_set_error_full): Impl (soup_message_set_handler_error): Impl (soup_get_error_phrase): Impl (soup_get_error_class): Impl * src/libsoup/soup-dav-server.c: Add a reference to the SoupServer we are registered with. Use soup_message_set_error throughout. (i_copy): Fix assignment causing this loop to never run. (soup_dav_server_register): Add SoupServer and required authtypes parameters. * src/libsoup/soup-context.c: Replace references to SoupServer with SoupHost, so we don't clash with the SoupServer from soup-server.h. Rename soup_servers to soup_hosts. * src/libsoup/Makefile.am (libsoup_la_SOURCES): Add soup-queue.h. * configure.in (SOUP_CURRENT): Add some helpful comments and bump to '3'. Bump version to 0.5.99 (0.6 development). Use AC_FUNC_ALLOCA instead of just checking for alloca.h. Remove WSDL_CFLAGS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 20 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index 5ae329bf..6b41246b 100644
--- a/configure.in
+++ b/configure.in
@@ -4,16 +4,21 @@ dnl *******************************************
AC_INIT(src/libsoup/soup.h)
-SOUP_CURRENT=2
-SOUP_REVISION=0
+# Increment on interface addition. Reset on removal.
SOUP_AGE=0
+# Increment on interface add, remove, or change.
+SOUP_CURRENT=3
+
+# Increment on source change. Reset when CURRENT changes.
+SOUP_REVISION=0
+
AC_SUBST(SOUP_CURRENT)
AC_SUBST(SOUP_REVISION)
AC_SUBST(SOUP_AGE)
# Update in src/soup-core/soup-private.h for Windows
-AM_INIT_AUTOMAKE(soup, 0.5.0)
+AM_INIT_AUTOMAKE(soup, 0.5.99)
AM_CONFIG_HEADER(config.h)
AM_MAINTAINER_MODE
@@ -194,6 +199,8 @@ AC_CHECK_HEADERS(sys/socket.h sys/sockio.h sys/poll.h sys/param.h sys/wait.h)
AC_CHECK_LIB(nsl, main)
AC_CHECK_LIB(resolv, main)
+AC_FUNC_ALLOCA
+
### Check if we have gethostbyname_r (if so, assume gethostbyaddr_r).
AC_CHECK_FUNC(gethostbyname_r,
[
@@ -266,10 +273,10 @@ if test -z "$HAVE_GETHOSTBYNAME_R"; then
AM_PATH_GLIB(1.2.0,
AC_DEFINE(HAVE_GETHOSTBYNAME_R_GLIB_MUTEX), [
AC_MSG_WARN(You have neither Glib threads nor the function
- gethostbyname_r. This means that calls to
- gethostbyname (called by the Soup address
- functions) will not be thread safe so could
- malfunction in programs that use threads.)
+ gethostbyname_r. This means that calls to
+ gethostbyname (called by the Soup address
+ functions) will not be thread safe so could
+ malfunction in programs that use threads.)
])
fi
@@ -279,7 +286,7 @@ dnl *** SSL Library checks (Mozilla NSS, or OpenSSL) ***
dnl ****************************************************
AC_ARG_ENABLE(ssl,
- [ --enable-ssl Turn on Secure Sockets Layer support [default=yes]],,
+ [ --enable-ssl Turn on Secure Sockets Layer support [default=yes]],,
enable_ssl=yes)
AC_ARG_WITH(nspr-includes,
@@ -387,7 +394,10 @@ AC_CHECK_PROG(DB2HTML, db2html, true, false)
AM_CONDITIONAL(HAVE_DOCBOOK, $DB2HTML)
dnl Let people disable the gtk-doc stuff.
-AC_ARG_ENABLE(gtk-doc, [ --enable-gtk-doc Use gtk-doc to build documentation [default=auto]], enable_gtk_doc="$enableval", enable_gtk_doc=auto)
+AC_ARG_ENABLE(gtk-doc,
+ [ --enable-gtk-doc Use gtk-doc to build documentation [default=auto]],
+ enable_gtk_doc="$enableval",
+ enable_gtk_doc=auto)
if test x$enable_gtk_doc = xauto ; then
if test x$GTKDOC = xtrue ; then
@@ -465,23 +475,13 @@ dnl *** Warnings to show if using GCC ***
dnl *************************************
AC_ARG_ENABLE(more-warnings,
- [ --enable-more-warnings Maximum compiler warnings],
- set_more_warnings="$enableval",
+ [ --disable-more-warnings Inhibit compiler warnings],
set_more_warnings=no)
if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
CFLAGS="$CFLAGS \
-Wall -Wstrict-prototypes -Wmissing-declarations \
-Wmissing-prototypes -Wnested-externs -Wpointer-arith"
-
- # -Wredundant-decls warns about libxml headers
- # -Wwrite-strings warns when defining GDebugKey structs (solved by
- # casting the strings in wsdl-trace.c and leaving out -Wcast-qual)
- WSDL_CFLAGS="-W -Wundef -Wshadow -Wbad-function-cast \
- -Wcast-align -Wwrite-strings -Wconversion \
- -Waggregate-return -Wmissing-noreturn"
-
- AC_SUBST(WSDL_CFLAGS)
fi
# Use reentrant functions