summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDick Porter <dick@ximian.com>2001-05-17 16:03:11 +0000
committerDick Porter <dick@src.gnome.org>2001-05-17 16:03:11 +0000
commitc4fabfc9505a81322ce0d1a9011bf20b25c717ed (patch)
treef2faa7d6800f68204464c6448775d26777f9174a /configure.in
parentd83827ff2971d1cb4fa677adcb03c2d57995f8fa (diff)
downloadlibsoup-c4fabfc9505a81322ce0d1a9011bf20b25c717ed.tar.gz
Extract gtk-doc documentation from the code
2001-05-17 Dick Porter <dick@ximian.com> * docs/reference: Extract gtk-doc documentation from the code * tests/test-wsdl-runtime.c: * tests/stockquote2-server.c: * tests/stockquote2-client.c: Updated for new API * tests/stress-test.c: * tests/simple-test.c: Include installed soup headers * configure.in: Check for gtk-doc * tests/Makefile.am: Made example code just plain "noinst_PROGRAMS", check_PROGRAMS are built as part of "make dist". Wrestled with automake, automake won :-( I wanted to delete the built sources from the dist target, and not have automake try and recreate them with a non-existant soup-wsdl when I type "make distcheck". * Makefile.am: Took tests out of SUBDIRS, added a "make examples" target instead.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in58
1 files changed, 57 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 35ab7207..f9c1ed19 100644
--- a/configure.in
+++ b/configure.in
@@ -14,6 +14,7 @@ AC_SUBST(SOUP_AGE)
AM_CONFIG_HEADER(config.h)
AM_INIT_AUTOMAKE(soup, 0.2.1)
AM_MAINTAINER_MODE
+AC_PROG_MAKE_SET
# ****************************************
@@ -376,8 +377,61 @@ AC_SUBST(WSDL_CFLAGS)
# Use reentrant functions
CFLAGS="$CFLAGS -D_REENTRANT"
+dnl *********************************************
+dnl *** Checks for gtk-doc (lifted from glib) ***
+dnl *********************************************
+
+AC_ARG_WITH(html-dir, [ --with-html-dir=PATH path to installed docs ])
+
+if test "x$with_html_dir" = "x" ; then
+ HTML_DIR='${datadir}/gtk-doc/html'
+else
+ HTML_DIR=$with_html_dir
+fi
+
+AC_SUBST(HTML_DIR)
+
+AC_CHECK_PROG(GTKDOC, gtkdoc-mkdb, true, false)
+
+gtk_doc_min_version=0.6
+if $GTKDOC ; then
+ gtk_doc_version=`gtkdoc-mkdb --version`
+ AC_MSG_CHECKING([gtk-doc version ($gtk_doc_version) >= $gtk_doc_min_version])
+ if perl <<EOF ; then
+ exit (("$gtk_doc_version" =~ /^[[0-9]]+\.[[0-9]]+$/) &&
+ ("$gtk_doc_version" >= "$gtk_doc_min_version") ? 0 : 1);
+EOF
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ GTKDOC=false
+ fi
+fi
+
+AM_CONDITIONAL(HAVE_GTK_DOC, $GTKDOC)
+AC_SUBST(HAVE_GTK_DOC)
+
+AC_CHECK_PROG(DB2HTML, db2html, true, false)
+AM_CONDITIONAL(HAVE_DOCBOOK, $DB2HTML)
+
+dnl Let people disable the gtk-doc stuff.
+AC_ARG_ENABLE(gtk-doc, [ --enable-gtk-doc Use gtk-doc to build documentation [default=auto]], enable_gtk_doc="$enableval", enable_gtk_doc=auto)
+
+if test x$enable_gtk_doc = xauto ; then
+ if test x$GTKDOC = xtrue ; then
+ enable_gtk_doc=yes
+ else
+ enable_gtk_doc=no
+ fi
+fi
+
+dnl NOTE: We need to use a separate automake conditional for this
+dnl to make this work with the tarballs.
+AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
+
+dnl *** End of gtk-doc section
+
-# doc/Makefile
AC_OUTPUT([
soup-config
@@ -389,6 +443,8 @@ AC_OUTPUT([
src/soup-wsdl/Makefile
src/soup-wsdl-runtime/Makefile
tests/Makefile
+ docs/Makefile
+ docs/reference/Makefile
])
echo "