summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2010-06-07 14:57:52 +0200
committerDan Winship <danw@gnome.org>2010-06-08 11:45:45 -0400
commit25bfd5cbcfb93b94efc7c0f6f0d4bbfa51244e42 (patch)
tree02ffa50d147ff4690468086d3d893416a1ffd1b4 /configure.ac
parent34ae2a292b69321078c5e7d922a39f75e8538d3a (diff)
downloadlibsoup-25bfd5cbcfb93b94efc7c0f6f0d4bbfa51244e42.tar.gz
SoupProxyResolverGNOME: improve behavior with more-recent libproxy
SoupProxyResolverGNOME had a nasty workaround for the fact that libproxy 0.2 would crash inside GConf if called from a thread other than the main one. Unfortunately, the workaround involves leaking proxy settings into the environment, which is particularly bad since gnome-panel uses libsoup (via libgweather via intlclock) and so the environment can become polluted for everything started from the panel. In libproxy 0.3 and later, the workaround is no longer necessary, so remove it if libproxy is new enough. https://bugzilla.gnome.org/show_bug.cgi?id=603285
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bc504ab1..ce1e9097 100644
--- a/configure.ac
+++ b/configure.ac
@@ -173,13 +173,24 @@ This is required for GNOME proxy support.
Pass "--without-gnome" to configure if you want to build libsoup
without GNOME support.])])
+ AC_MSG_CHECKING(libproxy version)
+ libproxy_version=`$PKG_CONFIG --modversion libproxy-1.0`
+ case $libproxy_version in
+ 0.2.*)
+ AC_MSG_RESULT([$libproxy_version, using workarounds...])
+ AC_DEFINE(HAVE_LIBPROXY_WITH_NON_THREAD_SAFE_GNOME_MODULE, 1, [Defined if libproxy is old and has a non-thread-safe gnome module])
+ ;;
+ *)
+ AC_MSG_RESULT([$libproxy_version, ok])
+ ;;
+ esac
+
PKG_CHECK_MODULES(GCONF, gconf-2.0, , [AC_MSG_ERROR(dnl
[Could not find GConf:
$GCONF_PKG_ERRORS
-Due to bugs in libproxy as of the GNOME 2.26 freeze date, GConf is
-*also* required for GNOME proxy support.
+This is required for GNOME proxy support.
Pass "--without-gnome" to configure if you want to build libsoup
without GNOME support.])])