summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2013-02-07 09:23:31 -0500
committerDan Winship <danw@gnome.org>2013-02-07 09:25:11 -0500
commit4f27350d0f6daf8719cdf5a2b6e71cf1771ff656 (patch)
tree9abc68e3a278a91186b68e314437a94602cb84cf /configure.ac
parent7ac58e8dacd7609ecf3fd551f26034ad974d56b0 (diff)
downloadlibsoup-4f27350d0f6daf8719cdf5a2b6e71cf1771ff656.tar.gz
tests: fix non-php apache tests to still work without php
Setting "IF_HAVE_PHP" to "#" actually sets it to "", because the "#" is treated as the start of a comment. We have to set it to "\#" if we want to cause the "#" to actually get substituted into httpd.conf https://bugzilla.gnome.org/show_bug.cgi?id=693311
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fc49a2bd..79026a57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -284,7 +284,7 @@ if test "$have_apache" = 1; then
IF_HAVE_PHP=""
else
have_php=no
- IF_HAVE_PHP="#"
+ IF_HAVE_PHP="\#"
MISSING_REGRESSION_TEST_PACKAGES="$MISSING_REGRESSION_TEST_PACKAGES php5"
fi
AC_MSG_RESULT($have_php)