summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authoralex <alex>2001-01-23 21:39:05 +0000
committeralex <alex>2001-01-23 21:39:05 +0000
commitd087f7492012c2a0232becdcb4146d525db8fca2 (patch)
tree40539c5cc26f114273f3b781133b01d8a99da65d /Makefile.am
parent06bb60dc2108ceb8f212dc3d81a587eeb7c57a99 (diff)
downloadlibsoup-d087f7492012c2a0232becdcb4146d525db8fca2.tar.gz
Created from rcs2log.
* ChangeLog: Created from rcs2log. * AUTHORS: Added Dick Porter. * soup.pc.in, soup-config.in, soupConf.sh, soup.m4: Created with a dash of Maintainer Love. * soup.spec.in: RPM spec file. Needs fixing wrt to displaying the OpenSSL license conditionally (if it was statically linked). * Makefile.am: Updated to install new config scripts and macros. * configure.in: add --enable-ssl, --with-ssl=[nss/openssl/none], and --with-nss-prefix=PFX to support choosing of an SSL library to use, even though openssl is the only one currently supported. * src/soup-core/Makefile.am: don't install soup-ssl.h or soup-socks.h, they're internal. * src/soup-core/soup-ssl.c: wrap openssl calls with a conditional to avoid building if --enable-ssl=no or NSS is chosen as the library. soup_get_ssl_iochannel() will print "SSL Not Supported." and return NULL if no library has been chosen. * tests/stress-test.c: make the callback handle errors by requeuing request and not just g_error'ing.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 12 insertions, 21 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a5aabeb..8abb0658 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,27 +2,18 @@
SUBDIRS = src tests
-EXTRA_DIST = \
- autogen.sh
+EXTRA_DIST = autogen.sh soupConf.sh.in soup.pc.in soup.spec.in
-install-data-local:
- @$(NORMAL_INSTALL)
- if test -d $(srcdir)/pixmaps; then \
- $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/pixmaps; \
- for pixmap in $(srcdir)/pixmaps/*; do \
- if test -f $$pixmap; then \
- $(INSTALL_DATA) $$pixmap $(DESTDIR)$(pkgdatadir)/pixmaps; \
- fi \
- done \
- fi
+bin_SCRIPTS = soup-config
-dist-hook:
- if test -d pixmaps; then \
- mkdir $(distdir)/pixmaps; \
- for pixmap in pixmaps/*; do \
- if test -f $$pixmap; then \
- cp -p $$pixmap $(distdir)/pixmaps; \
- fi \
- done \
- fi
+confexecdir = $(libdir)
+confexec_DATA = soupConf.sh
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = soup.pc
+
+dist-hook: soup.spec
+ cp soup.spec $(distdir)
+
+rpms: distcheck
+ rpm -ta $(top_builddir)/@PACKAGE@-@VERSION@.tar.gz