summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@ximian.com>2001-04-25 20:39:56 +0000
committerJP Rosevear <jpr@src.gnome.org>2001-04-25 20:39:56 +0000
commit503c30e84b895662f79a6554ce747c593c3f6034 (patch)
tree8105f8e23ad3182a06432f324bb3b4efd300a196 /Makefile.am
parent91768aae69a96b1329fca0cfd9fe2deb11c63f54 (diff)
downloadlibsoup-503c30e84b895662f79a6554ce747c593c3f6034.tar.gz
get this script working again and add wsdl
2001-04-25 JP Rosevear <jpr@ximian.com> * soup-config.in (lib_soup): get this script working again and add wsdl * Makefile.am: create and install new script * configure.in: create variables for script substitution * soup_wsdlConf.sh.in: gnome-config script for wsdl compilation info
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fa83da90..524325f1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,8 +22,16 @@ soup_apacheConf.sh: $(top_srcdir)/soup_apacheConf.sh.in Makefile
< $(top_srcdir)/soup_apacheConf.sh.in > soup_apacheConf.tmp \
&& mv soup_apacheConf.tmp soup_apacheConf.sh
+soup_wsdlConf.sh: $(top_srcdir)/soup_wsdlConf.sh.in Makefile
+ sed -e 's?\@SOUP_WSDL_LIBDIR\@?$(SOUP_WSDL_LIBDIR)?g' \
+ -e 's?\@SOUP_WSDL_INCLUDEDIR\@?$(SOUP_WSDL_INCLUDEDIR)?g' \
+ -e 's?\@VERSION\@?$(VERSION)?g' \
+ -e 's?\@SOUP_WSDL_LIBS\@?$(SOUP_WSDL_LIBS)?g' \
+ < $(top_srcdir)/soup_wsdlConf.sh.in > soup_wsdlConf.tmp \
+ && mv soup_wsdlConf.tmp soup_wsdlConf.sh
+
confexecdir = $(libdir)
-confexec_DATA = soupConf.sh soup_apacheConf.sh
+confexec_DATA = soupConf.sh soup_apacheConf.sh soup_wsdlConf.sh
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = soup.pc