summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@gnome.org>2023-02-28 13:36:34 -0600
committerFederico Mena Quintero <federico@gnome.org>2023-03-07 16:39:08 -0600
commit0a9c66f66008943ebf046e71682aae3814e2008b (patch)
tree96d29afbac1d111a78b332637b0ad11d8bb2963d /Makefile.am
parent451f8806a5f06add42407d19ab03aaea0b79fb11 (diff)
downloadlibrsvg-0a9c66f66008943ebf046e71682aae3814e2008b.tar.gz
(#644): Rename Rust crate to "rsvg"
This is more in line with the conventions for Rust crate names, instead of "librsvg". Thanks to Stefan Lau for ceding the name, which was previously used by the rsvg-rs bindings before librsvg itself provided a Rust API. Fixes https://gitlab.gnome.org/GNOME/librsvg/-/issues/644
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 24e47b34..1c88241e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -154,7 +154,7 @@ cargo_verbose_1 = --verbose
LIBRSVG_BUILD_DIR=@abs_top_builddir@
CARGO_TARGET_DIR=$(LIBRSVG_BUILD_DIR)/target
-RUST_LIB=$(CARGO_TARGET_DIR)/$(RUST_TARGET_SUBDIR)/liblibrsvg.a
+RUST_LIB=$(CARGO_TARGET_DIR)/$(RUST_TARGET_SUBDIR)/librsvg.a
check-local:
cd $(srcdir) && \