summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTomas Mraz <tmraz@redhat.com>2011-11-11 12:27:37 +0100
committerTomas Mraz <tmraz@redhat.com>2011-11-11 12:27:37 +0100
commitb095651ef79468801d2096d253604c5e8b2cf295 (patch)
tree9acdc2aa6dfbf35748c8c50c855ddaf4e41ffd4f /configure.in
parentf5e95154ea6894b9275ffc60a57cda51358c93ca (diff)
downloadlibpwquality-git-b095651ef79468801d2096d253604c5e8b2cf295.tar.gz
Add documentation. Prerelease 0.9.9 - RC candidate.libpwquality-0.9.9
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1faf793..3b72ec1 100644
--- a/configure.in
+++ b/configure.in
@@ -69,6 +69,7 @@ case "${host}" in
have_ld_version_script=yes
;;
esac
+
AC_ARG_ENABLE([ld-version-script],
AC_HELP_STRING([--enable-ld-version-script],
[enable/disable use of linker version script.
@@ -77,6 +78,7 @@ AC_ARG_ENABLE([ld-version-script],
[ : ] )
AM_CONDITIONAL(HAVE_LD_VERSION_SCRIPT, test "$have_ld_version_script" = "yes")
+dnl options and defaults
AC_ARG_WITH(securedir,
AS_HELP_STRING([--with-securedir=DIR],[path to location of PAMs @<:@default=$libdir/security@:>@]),
SECUREDIR=$withval, SECUREDIR=$libdir/security)
@@ -87,7 +89,6 @@ AC_ARG_WITH(sconfigdir,
SCONFIGDIR=$enableval, SCONFIGDIR=$sysconfdir/security)
AC_SUBST(SCONFIGDIR)
-dnl options and defaults
AC_ARG_WITH(python-rev,
[ --with-pythonrev=2.7 version of python for which modules should be built],
PYTHONREV=$withval,[
@@ -97,6 +98,15 @@ AC_ARG_WITH(python-rev,
])
AC_SUBST(PYTHONREV)
+AC_ARG_WITH(pythonsitedir,
+ [ --with-pythonsitedir=DIR directory of the python site packages @<:@default=$libdir/python$PYTHONREV/site-packages@:>@],
+ PYTHONSITEDIR=$withval,[
+ AC_MSG_CHECKING([python version])
+ [PYTHONSITEDIR=$libdir/python$PYTHONREV/site-packages]
+ AC_MSG_RESULT($PYTHONSITEDIR)
+ ])
+AC_SUBST(PYTHONSITEDIR)
+
dnl Check for cracklib
AC_CHECK_HEADERS([crack.h],
AC_CHECK_LIB([crack], [FascistCheck], LIBCRACK="-lcrack", LIBCRACK=""))
@@ -119,5 +129,6 @@ dnl Checks for library functions.
AC_CHECK_FUNCS(strcspn strdup strspn strstr strtol)
dnl Files to be created from when we run configure
-AC_CONFIG_FILES([Makefile libpwquality.spec src/Makefile po/Makefile.in python/Makefile])
+AC_CONFIG_FILES([Makefile libpwquality.spec src/Makefile po/Makefile.in python/Makefile
+ doc/Makefile doc/man/Makefile])
AC_OUTPUT