summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d2dd63a..75f1520 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,3 +14,22 @@ test1_LDADD = -lpopt
noinst_HEADERS = popt.h
noinst_LIBRARIES = libpopt.a
libpopt_a_SOURCES = popt.c findme.c poptparse.c poptconfig.c popthelp.c
+
+CVSTAG = $(PACKAGE)-$(subst .,_,$(VERSION))
+
+.PHONY: archive
+archive:
+ @echo "This is $(PACKAGE)-$(VERSION)."
+ @sleep 5
+ @cvs -Q tag -F $(CVSTAG) .
+ rm -rf /tmp/$(PACKAGE)-$(VERSION) /tmp/$(PACKAGE)
+ cd /tmp; cvs -Q -d $(CVSROOT) export -r$(CVSTAG) $(PACKAGE) || :
+ mv /tmp/$(PACKAGE) /tmp/$(PACKAGE)-$(VERSION)
+ cd /tmp/$(PACKAGE)-$(VERSION); ./autogen.sh ; make depend; make distclean
+ cd /tmp/$(PACKAGE)-$(VERSION); ./autogen.sh --noconfigure
+ cd /tmp; tar czSpf $(PACKAGE)-$(VERSION).tar.gz $(PACKAGE)-$(VERSION)
+ rm -rf /tmp/$(PACKAGE)-$(VERSION)
+ cp /tmp/$(PACKAGE)-$(VERSION).tar.gz .
+ rm -f /tmp/$(PACKAGE)-$(VERSION).tar.gz
+ @echo " "
+ @echo "The final archive is ./$(PACKAGE)-$(VERSION).tar.gz."