summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGlenn Randers-Pehrson <glennrp at users.sourceforge.net>2010-07-29 19:09:18 -0500
committerGlenn Randers-Pehrson <glennrp at users.sourceforge.net>2010-07-29 19:09:18 -0500
commit2be8b64af2e0e1fd172886685ab944019f7d739b (patch)
tree94968853f5d89db4b6b3785c79c6eca1f4107773 /Makefile.am
parenta7a76a674faea3fee415e742de82781a94eccdf7 (diff)
downloadlibpng-2be8b64af2e0e1fd172886685ab944019f7d739b.tar.gz
[devel] Update documentation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bfdb97037..e38dac441 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -105,6 +105,11 @@ scripts/pnglibconf.h:
@echo "a new one simply make 'scripts/pnglibconf.out' and copy that" >&2
@exit 1
+# The following is necessary to ensure that the local pnglibconf.h is used, not
+# an installed one (this can happen immediately after on a clean system if
+# 'make test' is the first thing the user does.)
+pngvalid.o pngtest.o: pnglibconf.h
+
SYMBOL_CFLAGS = -DPNGLIB_LIBNAME='PNG@PNGLIB_MAJOR@@PNGLIB_MINOR@_0'\
-DPNGLIB_VERSION='@PNGLIB_VERSION@'\
-DSYMBOL_PREFIX='$(SYMBOL_PREFIX)'