summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGlenn Randers-Pehrson <glennrp at users.sourceforge.net>2011-01-26 22:04:03 -0600
committerGlenn Randers-Pehrson <glennrp at users.sourceforge.net>2011-01-26 22:05:32 -0600
commit0012e9cd5462ce9f960855db066422279356887d (patch)
treeeb35a7a9c9ab6c3d7e5eb83fe459043de8a75096 /Makefile.am
parent8d0bc0f0261a0ee1fdbc57d28036662c11ab3053 (diff)
downloadlibpng-0012e9cd5462ce9f960855db066422279356887d.tar.gz
[devel] Imported from libpng-1.5.1beta10.tarv1.5.1beta10
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bff416557..142a4ceae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -118,6 +118,9 @@ scripts/pnglibconf.h.prebuilt:
# 'make test' is the first thing the user does.)
pngvalid.o pngtest.o: pnglibconf.h
+# We must use -DPNG_NO_USE_READ_MACROS here even when the library may actually
+# be built with PNG_USE_READ_MACROS; this stops the read macros interfering
+# with the symbol file format.
SYMBOL_CFLAGS = -DPNGLIB_LIBNAME='PNG@PNGLIB_MAJOR@@PNGLIB_MINOR@_0'\
-DPNGLIB_VERSION='@PNGLIB_VERSION@'\
-DSYMBOL_PREFIX='$(SYMBOL_PREFIX)'\