summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPino Toscano <ptoscano@redhat.com>2017-08-07 18:18:34 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2017-10-16 11:12:22 +0200
commitb61be0405f678986ac344f414fa907af24670488 (patch)
treebb851f541824ce4269d995d7b972f5ab4c456cc4 /configure.ac
parenta15586fd8f26dd10e13b8a523649f9240a8f817c (diff)
downloadlibosinfo-b61be0405f678986ac344f414fa907af24670488.tar.gz
Switch from libsoup to libcurl
libsoup is used to check the validity of URLs in distributions in osinfo-db; OTOH it supports only HTTP(S), so this limits the checks to that protocol. To overcome this limitation, switch to libcurl: while it requires slightly more code to do the same task, it provides a bit more flexibility, and support for other protocols. No version check is performed, since the APIs used are old enough. Adapt also the README, and the packaging files. Acked-by: Christophe Fergeau <cfergeau@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 3 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index e981e76..b3dab09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,10 +40,6 @@ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
GLIB_MINIMUM_VERSION="2.36"
GLIB_ENCODED_VERSION="GLIB_VERSION_2_36"
-# Keep these two definitions in agreement.
-SOUP_MINIMUM_VERSION="2.42"
-SOUP_ENCODED_VERSION="SOUP_VERSION_2_42"
-
PKG_CHECK_MODULES([LIBXML], [libxml-2.0 >= 2.6.0])
PKG_CHECK_MODULES([LIBXSLT], [libxslt >= 1.0.0])
@@ -53,11 +49,9 @@ GLIB_CFLAGS="$GLIB_CFLAGS -DGLIB_VERSION_MAX_ALLOWED=$GLIB_ENCODED_VERSION"
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
-PKG_CHECK_MODULES([SOUP], [libsoup-2.4 >= $SOUP_MINIMUM_VERSION])
-SOUP_CFLAGS="$SOUP_CFLAGS -DSOUP_VERSION_MIN_REQUIRED=$SOUP_ENCODED_VERSION"
-SOUP_CFLAGS="$SOUP_CFLAGS -DSOUP_VERSION_MAX_ALLOWED=$SOUP_ENCODED_VERSION"
-AC_SUBST(SOUP_CFLAGS)
-AC_SUBST(SOUP_LIBS)
+PKG_CHECK_MODULES([CURL], [libcurl])
+AC_SUBST(CURL_CFLAGS)
+AC_SUBST(CURL_LIBS)
GTK_DOC_CHECK([1.10],[--flavour no-tmpl])