summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2013-12-04 12:00:23 +0000
committerDaniel P. Berrange <berrange@redhat.com>2013-12-11 13:06:38 +0000
commitd7e4608d7b92467b1ab6514f2a322f88619c5bf6 (patch)
tree04cf6ed7e04d4494fb2f20a801f6382763a2bda4 /configure.ac
parent6cd8babe6100d638a6ea8260916c1640ebddbb63 (diff)
downloadlibosinfo-d7e4608d7b92467b1ab6514f2a322f88619c5bf6.tar.gz
Add scripts for validating the libosinfo.syms file
Import two test scripts from libvirt code which validate that all symbols in libosinfo.syms exist in the ELF binary, and also validate the alphabetical sorting. These are hooked up to run with 'make check'. Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 62c9a6f..aed1029 100644
--- a/configure.ac
+++ b/configure.ac
@@ -92,6 +92,13 @@ AC_SUBST([NO_UNDEFINED_FLAGS])
AC_SUBST([VERSION_SCRIPT_FLAGS])
AM_CONDITIONAL([USE_VERSION_DEFS], [test "$USE_VERSION_DEFS" = "1"])
+with_linux=no
+case $host in
+ *-*-linux*) with_linux=yes ;;
+esac
+AM_CONDITIONAL([WITH_LINUX], [test "$with_linux" = "yes"])
+
+
AC_ARG_ENABLE([introspection],
AS_HELP_STRING([--enable-introspection], [enable GObject introspection]),
[], [enable_introspection=check])