summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2013-04-08 16:51:03 +0100
committerDaniel P. Berrange <berrange@redhat.com>2013-04-09 11:36:13 +0100
commit7f8468d45db1699674e85e2945003606cd1ae4db (patch)
treedc6d0370b2b33679632b0cfe2e33cfaf9012b9c1 /Makefile.am
parent6e265bf3beb0206a30bc6620ed1c8843d469b24f (diff)
downloadlibosinfo-7f8468d45db1699674e85e2945003606cd1ae4db.tar.gz
Auto-generate AUTHORS file from GIT logs
Rather than trying to manually keep track of authors, just auto-generate the list from GIT logs Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 566ccac..7bb5c32 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,6 +23,7 @@ EXTRA_DIST = \
cfg.mk \
GNUmakefile \
maint.mk \
+ AUTHORS.in \
$(INTLTOOL_FILES) \
$(NULL)
@@ -59,16 +60,23 @@ cov: clean-cov
clean-cov:
rm -rf $(top_builddir)/coverage
-dist-hook: gen-ChangeLog
+dist-hook: gen-ChangeLog gen-AUTHORS
# Generate the ChangeLog file (with all entries since the switch to git)
# and insert it into the directory we're about to use to create a tarball.
-gen_start_date = 2009-07-04
-.PHONY: gen-ChangeLog
+.PHONY: gen-ChangeLog gen-AUTHORS
gen-ChangeLog:
if test -d .git; then \
$(top_srcdir)/build-aux/gitlog-to-changelog \
- --since=$(gen_start_date) > $(distdir)/cl-t; \
+ > $(distdir)/cl-t; \
rm -f $(distdir)/ChangeLog; \
mv $(distdir)/cl-t $(distdir)/ChangeLog; \
fi
+
+gen-AUTHORS:
+ $(AM_V_GEN)if test -d $(srcdir)/.git; then \
+ out="`cd $(srcdir) && git log --pretty=format:'%aN <%aE>' | sort -u`" && \
+ perl -p -e "s/#authorslist#// and print '$$out'" \
+ < $(srcdir)/AUTHORS.in > $(distdir)/AUTHORS-tmp && \
+ mv -f $(distdir)/AUTHORS-tmp $(distdir)/AUTHORS ; \
+ fi