summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am24
1 files changed, 18 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f2874a5..d9cadd0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,3 @@
-# $Id: Makefile.am,v 1.6 2004/11/09 07:05:07 mike Exp $
#
# Libnet automake information file
# Copyright (c) 1998 - 2004 Mike D. Schiffman <mike@infonexus.com>
@@ -6,9 +5,8 @@
#
# Process this file with automake to produce a Makefile.in script.
-include $(top_srcdir)/Makefile.am.common
-
EXTRA_DIST = libnet_dll.c common.h
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(builddir)/../include
lib_LTLIBRARIES = libnet.la
@@ -65,7 +63,8 @@ libnet_la_LIBADD = @LTLIBOBJS@
# Note: this version-info should NOT simply be the version of the libnet
# package. See:
-# http://www.sourceware.org/autobook/autobook/autobook_91.html
+# https://www.sourceware.org/autobook/autobook/autobook_61.html#Library-Versioning
+# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
# for the rules.
#
# Summary:
@@ -91,9 +90,22 @@ libnet_la_LIBADD = @LTLIBOBJS@
# 1.1.2.1-fork is 5:0:4
# 1.1.3 will be 6:0:5 -> new interfaces, backwards compatible
# 1.1.4 was 6:0:5 -> probably an error on my part
-# 1.1.5 is 7:0:6 -> new APIs, backwards compat
-# 1.1.6 is 8:0:7 -> new APIs, backwards compat
+# 1.1.5 is 7:0:6 -> new APIs, backwards compatible
+# 1.1.6 is 8:0:7 -> new APIs, backwards compatible
# 1.2 is 9:0:0 -> new APIs, removed __libnet_print_vers (internal, should not have been used, but linkable) APIs
libnet_la_LDFLAGS = -version-info 9:0:0
+## Windows stuff
+
+if WIN32
+libnet_la_LDFLAGS += -no-undefined
+# don't do any of this if we're not building shared libnet
+if COND_SHARED
+libnet_la_SOURCES += libnet_dll_info.rc
+libnet_la_LDFLAGS += -Wl,--output-def, -Wl,libnet-9.def
+
+.rc.lo:
+ $(AM_V_GEN)$(LIBTOOL) --mode=compile --silent $(WINDRES) $< -o $@
+endif
+endif \ No newline at end of file