summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBarak A. Pearlmutter <barak+git@cs.nuim.ie>2014-05-09 10:41:31 +0100
committerJoachim Nilsson <troglobit@gmail.com>2019-09-28 11:19:27 +0200
commitc3b67b7c5393e0bd1f19644d81fe49aaf256398b (patch)
treebefc468d6d934708f3113c488b8f1dd157d4c081 /configure.ac
parent6b8f2e1ce103e02696b413db88081b0da9796463 (diff)
downloadlibnet-c3b67b7c5393e0bd1f19644d81fe49aaf256398b.tar.gz
Use standard autotools doxygen support.
Generation of PDF doxygen documentation is enabled by default, can be disabled with $ ./configure --disable-doxygen-pdf This uses ax_prog_doxygen.m4 which is part of the GNU autoconf archive. A copy of /usr/share/aclocal/ax_prog_doxygen.m4 is put in m4/ This is invoked in configure.ac, and requires a macro in Makefile.am
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 22 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b8f7cb8..0bdb1dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,7 @@ AC_MSG_RESULT(beginning autoconfiguration process for libnet-${PACKAGE_VERSION}
AC_CANONICAL_TARGET
AC_CONFIG_SRCDIR([src/libnet_build_ip.c])
AC_CONFIG_MACRO_DIR([m4])
-AM_INIT_AUTOMAKE
+AM_INIT_AUTOMAKE([foreign subdir-objects no-dependencies -Wall])
AC_CONFIG_HEADERS([include/config.h])
dnl
@@ -20,9 +20,30 @@ AC_PROG_INSTALL
AC_USE_SYSTEM_EXTENSIONS
dnl disable shared libraries (for now)
dnl AC_DISABLE_SHARED
+AM_PROG_AR
LT_INIT
dnl
+dnl Check for DOxygen and enable its features
+dnl
+
+# See /usr/share/aclocal/ax_prog_doxygen.m4 and
+# http://www.bioinf.uni-freiburg.de/~mmann/HowTo/automake.html#doxygenSupport
+
+DX_DOXYGEN_FEATURE(ON)
+DX_DOT_FEATURE(ON)
+DX_HTML_FEATURE(ON)
+DX_CHM_FEATURE(OFF)
+DX_CHI_FEATURE(OFF)
+DX_MAN_FEATURE(ON)
+DX_RTF_FEATURE(OFF)
+DX_XML_FEATURE(OFF)
+DX_PDF_FEATURE(ON)
+DX_PS_FEATURE(OFF)
+DX_INIT_DOXYGEN(${PACKAGE_NAME}, [doc/libnet.doxygen.conf])
+AM_CONDITIONAL(ENABLE_DOXYGEN,[test "x${DX_FLAG_doc}" = x1])
+
+dnl
dnl Check for headers
dnl