summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2015-07-23 11:29:32 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2015-07-24 08:48:19 +1000
commit2a11010467e977c05225e97cb42f81ab40b6d220 (patch)
tree3b1378f5a7efe96d974c1bd8caa1ac1a4d7f53ed /test/Makefile.am
parente4a43c19b19ea55aa839fbba8cf6c328254a4442 (diff)
downloadlibinput-2a11010467e977c05225e97cb42f81ab40b6d220.tar.gz
test: split button tests into separate binary
We're again hitting the fork ulimits again (see also 9c2afae14) causing test case failures in the valgrind run of the touchpad test. Split out the touchpad button tests so we don't require special ulimits on test boxes. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 909bd48a..1c2852e2 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -55,6 +55,7 @@ endif
run_tests = \
test-touchpad \
test-touchpad-tap \
+ test-touchpad-buttons \
test-device \
test-gestures \
test-pointer \
@@ -107,6 +108,10 @@ test_touchpad_tap_SOURCES = touchpad-tap.c
test_touchpad_tap_LDADD = $(TEST_LIBS)
test_touchpad_tap_LDFLAGS = -no-install
+test_touchpad_buttons_SOURCES = touchpad-buttons.c
+test_touchpad_buttons_LDADD = $(TEST_LIBS)
+test_touchpad_buttons_LDFLAGS = -no-install
+
test_trackpoint_SOURCES = trackpoint.c
test_trackpoint_LDADD = $(TEST_LIBS)
test_trackpoint_LDFLAGS = -no-install