summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJonas Ådahl <jadahl@gmail.com>2014-03-24 23:45:05 +0100
committerJonas Ådahl <jadahl@gmail.com>2014-03-29 00:51:44 +0100
commit07750ef7988a98c1b3216fb6d52937c9ca07b539 (patch)
treed02a8d7dadb09aad900be779fbb49ef808c1d041 /test/Makefile.am
parent7b3b5f173bb17efa52c541cceb4c0d0ded977dc3 (diff)
downloadlibinput-07750ef7988a98c1b3216fb6d52937c9ca07b539.tar.gz
test: Add include from C++ build test
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index e05b8727..e111a124 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -20,7 +20,11 @@ liblitest_la_SOURCES = \
litest.c
run_tests = test-udev test-path test-pointer test-touch test-log test-touchpad
-build_tests = test-build-linker test-build-pedantic-c99 test-build-std-gnuc90
+build_tests = \
+ test-build-cxx \
+ test-build-linker \
+ test-build-pedantic-c99 \
+ test-build-std-gnuc90
noinst_PROGRAMS = $(build_tests) $(run_tests)
TESTS = $(run_tests)
@@ -67,4 +71,8 @@ test_build_linker_SOURCES = build-pedantic.c
test_build_linker_CFLAGS = -I$(top_srcdir)/src
test_build_linker_LDADD = $(top_builddir)/src/libinput.la
+# test including from C++
+test_build_cxx_SOURCES = build-cxx.cc
+test_build_cxx_CXXFLAGS = -Wall -Wextra -Wno-unused-parameter $(AM_CXXFLAGS)
+
endif