summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2020-09-09 11:42:17 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2020-09-09 13:57:39 +1000
commitc6f87ade8445902b841f4a7916b3c5daca5f1926 (patch)
treeba9ed760a959af2fe81de201f51f8a177fa896e9 /meson.build
parentad2216b4c8276f900fcc51e6c135f3c9abde2a4f (diff)
downloadlibinput-c6f87ade8445902b841f4a7916b3c5daca5f1926.tar.gz
meson.build: drop the separate cpp flags
All we care about for C++ is that we build. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 7 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 5c8bf1b3..963c25b8 100644
--- a/meson.build
+++ b/meson.build
@@ -42,10 +42,14 @@ libinput_so_version = '@0@.@1@.@2@'.format((libinput_lt_c - libinput_lt_a),
# Compiler setup
cc = meson.get_compiler('c')
-cppflags = ['-Wno-unused-parameter', '-fvisibility=hidden']
-cflags = cppflags + ['-Wmissing-prototypes', '-Wstrict-prototypes']
+cflags = [
+ '-Wno-unused-parameter',
+ '-Wmissing-prototypes',
+ '-Wstrict-prototypes'
+
+ '-fvisibility=hidden',
+]
add_project_arguments(cflags, language : 'c')
-add_project_arguments(cppflags, language : 'cpp')
# config.h
config_h = configuration_data()