summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2019-11-06 11:48:49 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2019-11-06 11:48:49 +1000
commit3205c29c600e647ba6710b0d9fced716ed6ab541 (patch)
treedab6777b79d07fd4ba412be9620b73cb90428703 /meson.build
parenteab156ef74a9977cc61a16b2320aeeea8f8fc8d8 (diff)
downloadlibinput-3205c29c600e647ba6710b0d9fced716ed6ab541.tar.gz
meson.build: drop the explicit -g flag
Let's rely on meson to set this for us. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 84f67f50..51dbd7da 100644
--- a/meson.build
+++ b/meson.build
@@ -43,7 +43,7 @@ libinput_so_version = '@0@.@1@.@2@'.format((libinput_lt_c - libinput_lt_a),
# Compiler setup
cc = meson.get_compiler('c')
-cppflags = ['-Wno-unused-parameter', '-g', '-fvisibility=hidden']
+cppflags = ['-Wno-unused-parameter', '-fvisibility=hidden']
cflags = cppflags + ['-Wmissing-prototypes', '-Wstrict-prototypes']
add_project_arguments(cflags, language : 'c')
add_project_arguments(cppflags, language : 'cpp')