summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2018-09-14 14:03:09 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2019-06-07 01:03:21 +0000
commitbf4277623f7c24286b9f1e4b3ace51fbb5bb6a98 (patch)
tree2165eb35a34a6d15b03015c4d6e9420c661cb3f5 /meson.build
parent17d792445edd689edc5b83608dbca51a1ab9e6fa (diff)
downloadlibinput-bf4277623f7c24286b9f1e4b3ace51fbb5bb6a98.tar.gz
Add a new dispatch interface for the Dell Canvas Totem
This device looks similar to a MT device on the kernel side, but it's not a MT device and it's not quite a tablet either. It uses slots to track up to 4 totems off the same device and the only hint that it's not a MT device is that it sends ABS_MT_TOOL_TYPE / MT_TOOL_DIAL. udev thinks it's a touchscreen and a tablet but we currently init those devices as touchscreen (because all wacom tablet touch devices are udev tablets+tochscreens). So we need a quirk to hook onto this device. And we use a completely separate dispatch implementation, because adding the behavior to the tablet interface requires so many exceptions that it's easier to just add a separate dispatch interface. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e54bb051..77f27d05 100644
--- a/meson.build
+++ b/meson.build
@@ -307,6 +307,7 @@ src_libinput = src_libfilter + [
'src/evdev-debounce.c',
'src/evdev-fallback.c',
'src/evdev-fallback.h',
+ 'src/evdev-totem.c',
'src/evdev-middle-button.c',
'src/evdev-mt-touchpad.c',
'src/evdev-mt-touchpad.h',
@@ -709,6 +710,8 @@ if get_option('tests')
'test/litest-device-bcm5974.c',
'test/litest-device-calibrated-touchscreen.c',
'test/litest-device-cyborg-rat-5.c',
+ 'test/litest-device-dell-canvas-totem.c',
+ 'test/litest-device-dell-canvas-totem-touch.c',
'test/litest-device-elantech-touchpad.c',
'test/litest-device-generic-singletouch.c',
'test/litest-device-gpio-keys.c',
@@ -851,6 +854,7 @@ if get_option('tests')
'test/test-touch.c',
'test/test-log.c',
'test/test-tablet.c',
+ 'test/test-totem.c',
'test/test-pad.c',
'test/test-touchpad.c',
'test/test-touchpad-tap.c',