summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2019-06-25 09:37:25 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2019-06-26 03:23:55 +0000
commitb12084ef76f73757e254208dd55cf2018842ff15 (patch)
tree53ff12cb747b1d67e40340d03a7900e53a05586a /meson.build
parent1f59f062660b715e08133ff3b390b67d86d68f26 (diff)
downloadlibinput-b12084ef76f73757e254208dd55cf2018842ff15.tar.gz
tools: skip debug-gui option testing if the debug-gui is disabled
Fixes #311 Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e2af8a53..35236571 100644
--- a/meson.build
+++ b/meson.build
@@ -612,8 +612,14 @@ executable('ptraccel-debug',
# Don't run the test during a release build because we rely on the magic
# subtool lookup
if get_option('buildtype') == 'debug' or get_option('buildtype') == 'debugoptimized'
+ config_tool_option_test = configuration_data()
+ config_tool_option_test.set('MESON_ENABLED_DEBUG_GUI', get_option('debug-gui'))
+ tool_option_test = configure_file(input: 'tools/test-tool-option-parsing.py',
+ output: '@BASENAME@',
+ configuration : config_tool_option_test,
+ install : false)
test('tool-option-parsing',
- find_program('tools/test-tool-option-parsing.py'),
+ tool_option_test,
args : ['--tool-path', libinput_tool.full_path()],
suite : ['all', 'root'],
timeout : 240)