summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2019-06-27 11:12:58 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2019-06-27 11:17:28 +1000
commitaa538dc5c8ecf91a4f56167b4b820690a48841f4 (patch)
treef31ef1e73709ec445640b1dd4ad37dfdce058f4a /meson.build
parent6a489b063655c9599bda90241b3253ea5cdfeeed (diff)
downloadlibinput-aa538dc5c8ecf91a4f56167b4b820690a48841f4.tar.gz
meson: force litest to use the right udev rules
We generate litest-specific udev rules that contain the path to the binaries in the builddir. But litest wasn't using those, so IMPORT would run things in /usr/lib/udev instead. Thus any changes to those binaries generated false test results depending on how compatible the system-installed libinput was. This is why 410b157 passed the test suite for example. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 315632a6..255f7f76 100644
--- a/meson.build
+++ b/meson.build
@@ -803,9 +803,11 @@ if get_option('tests')
litest_config_h = configuration_data()
litest_config_h.set_quoted('LIBINPUT_DEVICE_GROUPS_RULES_FILE',
- join_paths(meson.build_root(), '80-libinput-device-groups.rules'))
+ join_paths(meson.build_root(),
+ '80-libinput-device-groups-litest.rules'))
litest_config_h.set_quoted('LIBINPUT_FUZZ_OVERRIDE_UDEV_RULES_FILE',
- join_paths(meson.build_root(), '90-libinput-fuzz-override.rules'))
+ join_paths(meson.build_root(),
+ '90-libinput-fuzz-override-litest.rules'))
def_no_main = '-DLITEST_NO_MAIN'
def_disable_backtrace = '-DLITEST_DISABLE_BACKTRACE_LOGGING'