summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2019-11-05 16:17:01 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2019-11-19 09:56:14 +1000
commit733eb07eda50f944454955d30cacdbb7766a73ff (patch)
tree8b3280f94e2dbb04d8b2ae777f37c43e0615380c /meson.build
parent2c613feb0cbf4f6c79b0638688ca699f0c6fc0d3 (diff)
downloadlibinput-733eb07eda50f944454955d30cacdbb7766a73ff.tar.gz
tools: add a tablet debugging tool
Nothing sophisticated but easier to debug certain tablet oddities. It shows a bar for each axis on the tablet (and the evdev axis) and prints that relative to the axis range. This makes it easy to check if we do hit the full range (especially for distance/pressure/tilt) and whether that matches with what the device gives us. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 51dbd7da..e1e02dd1 100644
--- a/meson.build
+++ b/meson.build
@@ -495,6 +495,20 @@ configure_file(input : 'tools/libinput-debug-events.man',
install_dir : dir_man1,
)
+libinput_debug_tablet_sources = [ 'tools/libinput-debug-tablet.c' ]
+executable('libinput-debug-tablet',
+ libinput_debug_tablet_sources,
+ dependencies : deps_tools,
+ include_directories : [includes_src, includes_include],
+ install_dir : libinput_tool_path,
+ install : true)
+
+configure_file(input : 'tools/libinput-debug-tablet.man',
+ output : 'libinput-debug-tablet.1',
+ configuration : man_config,
+ install_dir : dir_man1,
+ )
+
libinput_quirks_sources = [ 'tools/libinput-quirks.c' ]
libinput_quirks = executable('libinput-quirks',
libinput_quirks_sources,