summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2019-11-27 07:28:27 +1000
committerBenjamin Tissoires <benjamin.tissoires@gmail.com>2019-11-28 11:52:54 +0100
commit3ac525db195f11c748fecfe8701e042f50300e40 (patch)
tree596cb60a6f431de3705315525cbc5fddf0d4e4f6 /meson.build
parent773b322e8b4a044de7f6c7ec72796fd96a376ef9 (diff)
downloadlibinput-3ac525db195f11c748fecfe8701e042f50300e40.tar.gz
test: write our test case results out as junit xml files
libcheck has the ability to write out XML files for test results, but converting those into junit isn't ideal, for a number of reasons: - junit xml is different to libcheck's xml, so not all data is available or useful. Especially with our litest wrappers around it. - litest forking off tests means we have to wrap around everything anyway to avoid multiple forks writing to the same test file. This is the minimal implementation since it's only user is likely the CI which we control fairly tightly. So there are a few corners we can skip: - no filename validation is performed by litest - we write out a lot of junit xml files (one per litest fork). Rather than collating those we just rely on the CI to find the files. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 0e5523fe..f79ef4f1 100644
--- a/meson.build
+++ b/meson.build
@@ -964,7 +964,8 @@ if get_option('tests')
test('libinput-test-suite-@0@'.format(group),
libinput_test_runner,
suite : ['all', 'valgrind', 'root', 'hardware'],
- args : ['--filter-group=@0@:*'.format(group)],
+ args : ['--filter-group=@0@:*'.format(group),
+ '--xml-output=junit-@0@-XXXXXX.xml'.format(group)],
is_parallel : false,
timeout : 1200)
endforeach
@@ -972,7 +973,8 @@ if get_option('tests')
test('libinput-test-deviceless',
libinput_test_runner,
suite : ['all', 'valgrind'],
- args: ['--filter-deviceless'])
+ args: ['--filter-deviceless',
+ '--xml-output=junit-deviceless-XXXXXX.xml'])
valgrind = find_program('valgrind', required : false)
if valgrind.found()