summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2019-04-05 11:02:46 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2019-04-09 13:41:03 +1000
commit32bf9f29909015a6fbec4252a0aea2151ccb0272 (patch)
treec2d0fefae601473fe13ad0d019eb80c3a9e186b9 /meson.build
parent80a52c28df26f1b592baa6240a5fe1343d18fafd (diff)
downloadlibinput-32bf9f29909015a6fbec4252a0aea2151ccb0272.tar.gz
tools: fix waiting for the tool to quit in the options test
Just use the wait() timeout directly instead of sleep and kill. This allows us to have a longer timeout and still get fast handling where the tool immediately exits, but less failure when running on busy machines. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6a6dad2b..03e4394b 100644
--- a/meson.build
+++ b/meson.build
@@ -610,7 +610,7 @@ if get_option('buildtype') == 'debug' or get_option('buildtype') == 'debugoptimi
test('tool-option-parsing',
find_program('tools/test-tool-option-parsing.py'),
args : ['--tool-path', libinput_tool.full_path()],
- timeout : 120)
+ timeout : 240)
endif
# the libinput tools check whether we execute from the builddir, this is