summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2019-04-30 13:10:42 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2019-05-07 04:48:00 +0000
commit01efe9de4f946c786dd13bbd082399106ccf077a (patch)
tree3d602862ee5dd40af09424f019ff70edb1c47d37 /meson.build
parent40f3e2603f38ddf8d9aea7f464c7eec4b724f193 (diff)
downloadlibinput-01efe9de4f946c786dd13bbd082399106ccf077a.tar.gz
test: replace the USING_VALGRIND env with the valgrind.h header
This header is intended to be included in the project, so let's do that and have proper runtime detection of the valgrind environment. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index a87a322c..83c51366 100644
--- a/meson.build
+++ b/meson.build
@@ -776,7 +776,8 @@ if get_option('tests')
'test/litest-device-xen-virtual-pointer.c',
'test/litest-device-vmware-virtual-usb-mouse.c',
'test/litest-device-yubikey.c',
- 'test/litest.c'
+ 'test/litest.c',
+ 'include/valgrind/valgrind.h'
]
dep_dl = cc.find_library('dl')
@@ -890,7 +891,6 @@ if get_option('tests')
if valgrind.found()
valgrind_env = environment()
valgrind_env.set('CK_FORK', 'no')
- valgrind_env.set('USING_VALGRIND', '1')
valgrind_suppressions_file = join_paths(dir_src_test, 'valgrind.suppressions')
add_test_setup('valgrind',
exe_wrapper : [ valgrind,